关键词[PHP]相关搜索结果,共搜索到8028条结果

PHP常用命令

查询PHP.ini位置php--ini

快速定位php.ini的位置

执行/usr/local/php/bin/php-ini|grepphp.ini

CentOS7之php-fpm篇

1.查看php-fpm状态systemctlstatusphp-fpm2.启动php-fpmsystemctlstartphp-fpm3.停止php-fpmsystemctlstopphp-fpm4.重启php-fpmsystemctlrestartphp-fpm

yum源安装php7.4

安装源yuminstallepel-releaseyuminstallhttp://rpms.remirepo.net/enterprise/remi-release-7.rpm安装管理工具 yuminstallyum-utils安装yuminstallphp74-php-gdphp74-php-pdophp74-php-mbstringphp74-php-cliphp74-php-fpmphp74-php-mysqlnd启动servicephp74-php-fpmstart

sql注入关键字

_info.php?id=inurl:event.php?id=inurl:faq2.php?id=inurl:fellows.php?id=inurl:fiche_spectacle.php?id=inurl:forum_bds.php?num=inurl:galeri_info.php?l=inurl:gallery.php?id=inurl:game.php?id=inurl:games.php?id=inurl:historialeer.php?num=inurl:hosting_info.php?id=inurl:humor.php?id=inurl:index.php?=inur

通过php docker快速验证简单代码

假设php脚本如下a.php<?phpecho"OK";启动phpclidockerdockerrun-it--rmphp:cli-alpine3.10shphp-fa.php

查询mac序列号详细信息包含-》生产日期

https://appleserialnumberinfo.com/Desktop/index.php

JSON相关

中文不转码(php):json_encode($data,JSON_UNESCAPED_UNICODE);

php jwt组件

https://packagist.org/packages/firebase/php-jwt

centos下批量删除具有相同特征的文件

find/目录-name"*.php"|xargsrm-f

program language

php  pythonjavaC语言C#

php宝塔遇到An another FPM instance seems to already listen on /tmp/php-cgi-71.sock

rm-rf/tmp/php-cgi-71.sock删除在重新启动php-fpm即可解决

php-数字精确计算

bc函数库https://www.php.net/manual/zh/ref.bc.php

php实现kafka功能开发

php/72/bin/peclinstallhttp://pecl.php.net/get/uuid-1.1.0.tgzlinux安装phprdkafka扩展参考perl安装篇/www/server/php/72/bin/peclinstallhttps://pecl.php.net/get/rdkafka-4.1.1.tgzlinuxphp.ini中配置extension=/www/server/php/72/lib/php/extensions/no-debug-non-zts-20170718/rdkafka.soextension=/www/server/php/72/lib/php

关于PHP包含文件的方法

含/c.php,正常情况下在/php/b.php中用一下代码是不会出错的:include"../c.php";然而,PHP坑爹的地方就在于,/a.php包含了/php/b.php后,/php/b.php里面的include"../c.php";语句就出错了,因为被/a.php包含之后相当于/php/b.php也位于/中了解决方法是在/php/b.php文件里,include语句改为:dirname(__FILE__)."../c.php";dirname(__FILE__)的作用是无论/php/b.php被誰包含了,include语句里都有以/php/b.php所在的路径为准,不会改变原有的

composer 安装 指定php版本

php版本情况有时候环境变量的php版本(php-v)不是我们实际项目所使用的php版本 这时候就需要使用实际项目使用的php版本安装composer/www/server/php/72/bin/php/usr/bin/composerinstall

php日志监控和排查

命令行:PHP错误日志vim/usr/local/php-v/etc/php.ini或者/etc/php.inidisplay_errors=Onerror_log="/data/phplog/error_log"chmoda+w/data/phplog/error_log开启PHP错误日志级别ini_set("display_errors",On);ini_set("error_reporting",E_ALL);php-fpm模式:错误日志配置文件vim/etc/php-fpm.conf或者自定义安装目录vim/etc/php-fpm.d/www.conf日志目录error_log=/va

linux php安装 curl 扩展

php的源码目录,cdextcdcurl/usr/local/php/bin/phpize./configure--with-php-config=/usr/local/php/bin/php-config--with-curl=DIR然后就是编译安装:makemakeinstall到这里会提示生成文件curl.so的路径: /usr/local/php/lib/php/extensions/no-debug-non-zts-xxxxxxxxx/进入到这个路径下,复制curl到extension_dir目录下(本目录路径可以看phpinfo可是直接看php.int),修改php.

php各版本下载

315:46php-5.5.1.tar.xz993970018-Jul-201315:46php-5.5.10.tar.bz21310274206-Mar-201408:44php-5.5.10.tar.bz2.asc49006-Mar-201408:44php-5.5.10.tar.gz1691941506-Mar-201408:44php-5.5.10.tar.gz.asc49006-Mar-201408:44php-5.5.10.tar.xz1056307606-Mar-201408:44php-5.5.10.tar.xz.asc49006-Mar-201408:44php-5.5.1

1 2 3 4 5 6 7 8 9 10 下一页