安装node-sass出现上面的报错问题

需要安装对应版本的node.js 和 node-sass

我安装的版本如下

"sass-loader":  "^7.1.0",

 "node-sass":  "^4.12.0"

node.js 版本为 13.6

标签智能推荐:

Error:Node Sass version 5.0.0 is incompatible with ^4.x 解决

node-sass版本不兼容,解决如下:移除原版本yarnremovenode-sass安装低版本yarnaddnode-sass@4.14.1

vue-cli使用脚手架安装,出现的各种问题

bsp;@babel/preset-env;安装node-sass和sass-loader的版本,有限制条件,目前,安装sass-loader的版本是12.0.0,会出现下面这种报错 原因是,sass-loader安装的时候,版本太高,和webpack已有的版本有冲突了,而我强制使用了cnpm进行成功安装,这样可能导致,package-lock.js中,不同的依赖包对应的webpack的

Node Sass version 7.0.0 is incompatible with xxxx.

早上拉公司项目跑的时候,解决了install安装模块失败之后又报了这个错误 然后查了下发现是nodesass版本不兼容而且node-sass已经弃用了只需要把node-sass卸载了在重新安装sass即可 npmuninstallnode-sass npminstallsass

Error:Node Sass version 5.0.0 is incompatible with ^4.0.0 问题解决

解决方案:卸载node-sassnpmuninstallnode-sass然后安装最新版本(5.0之前)npminstallnode-sass@4.14.1

nodejs版本控制和切换

是sass相关插件版本不对,卸载掉原来的版本,(先删sass-loader,再删node-sass)npmuninstallsass-loadernpmuninstallnode-sass 查找发现,node的16版本对应的node-sass,sass-loader版本"node-sass":"^6.0.1","sass-loader":"^10.2.0", 然后安装上面提到的

sass开发过程中遇到的几个坑

地址/安装sassgeminstallsass--http-proxyhttp://代理地址/最后安装成功了,参见图片2.sass中文注释报错打开C:\Ruby22-x64\lib\ruby\gems\2.2.0\gems\sass-3.4.22\lib\sass\engine.rb文件在文件下添加一行Encoding.default_external=Encoding.find('utf-8')

安装node-sass正确姿势

在项目目录下临时安装指定node-sass为镜像淘宝npminode-sass--sass_binary_site=https://npm.taobao.org/mirrors/node-sass/

解决Node Sass does not yet support your current environment

一、先卸载node-sass:npmuninstallnode-sass二、再安装node-sass:cnpmi-Dnode-sass三、以管理员身份运行cmd,运行以下命令:setSASS_BINARY_PATH=D:\win32-x64-64_binding.node

VUE : npm run dev 出现样式 Sysntax Error : ..\..\node_module\node-sass\v4.13.1:1

les\node-sass\v4.13.1:1SyntaxError: InvalidorunexpectedtokenatcompileFunction(<anonymous>)出现以上问题后,不要慌,如果你尝试删除掉项目里下载好的依赖再重装,你会发现还是会出现同样的问题,如果更极端一点,卸载掉 node npm 、vue脚手架 重新

ERROR in Cannot find module 'node-sass'

ERROR in Cannotfind module 'node-sass'错误表示找不到node-sass模块。因为cnpm安装导致的,换成npm安装就好或者cnpminstallnode-sass@latest解决方法:输入命令:cnpminstallnode-sass@latest