系统:CentOS 7  (防火墙关闭状态)

Nginx 是 C语言 开发,建议在 Linux 上运行,当然,也可以安装 Windows 版本,本篇则使用 CentOS 7 作为安装环境。

# rpm -qa|grep gcc

一. gcc 安装
安装 nginx 需要先将官网下载的源码进行编译,编译依赖 gcc 环境,如果没有 gcc 环境,则需要安装:

yum install gcc-c++

二. PCRE pcre-devel 安装
PCRE(Perl Compatible Regular Expressions) 是一个Perl库,包括 perl 兼容的正则表达式库。nginx 的 http 模块使用 pcre 来解析正则表达式,所以需要在 linux 上安装 pcre 库,pcre-devel 是使用 pcre 开发的一个二次开发库。nginx也需要此库。命令:

yum install -y pcre pcre-devel

三. zlib 安装
zlib 库提供了很多种压缩和解压缩的方式, nginx 使用 zlib 对 http 包的内容进行 gzip ,所以需要在 Centos 上安装 zlib 库。

yum install -y zlib zlib-devel

四. OpenSSL 安装
OpenSSL 是一个强大的安全套接字层密码库,囊括主要的密码算法、常用的密钥和证书封装管理功能及 SSL 协议,并提供丰富的应用程序供测试或其它目的使用。
nginx 不仅支持 http 协议,还支持 https(即在ssl协议上传输http),所以需要在 Centos 安装 OpenSSL 库。

yum install -y openssl openssl-devel

官网下载

1.直接下载.tar.gz安装包,地址:https://nginx.org/en/download.html

nginx.png

2.使用wget命令下载(推荐)。

wget -c https://nginx.org/download/nginx-1.10.1.tar.gz

nginx-wget.png

我下载的是1.10.1版本,这个是目前的稳定版。

解压

依然是直接命令:

tar -zxvf nginx-1.10.1.tar.gz
cd nginx-1.10.1

配置

其实在 nginx-1.10.1 版本中你就不需要去配置相关东西,默认就可以了。当然,如果你要自己配置目录也是可以的。
1.使用默认配置

./configure

2.自定义配置(不推荐)

./configure \
--prefix=/usr/local/nginx \
--conf-path=/usr/local/nginx/conf/nginx.conf \
--pid-path=/usr/local/nginx/conf/nginx.pid \
--lock-path=/var/lock/nginx.lock \
--error-log-path=/var/log/nginx/error.log \
--http-log-path=/var/log/nginx/access.log \
--with-http_gzip_static_module \
--http-client-body-temp-path=/var/temp/nginx/client \
--http-proxy-temp-path=/var/temp/nginx/proxy \
--http-fastcgi-temp-path=/var/temp/nginx/fastcgi \
--http-uwsgi-temp-path=/var/temp/nginx/uwsgi \
--http-scgi-temp-path=/var/temp/nginx/scgi

注:将临时文件目录指定为/var/temp/nginx,需要在/var下创建temp及nginx目录

编译安装

make
make install

查找安装路径:

whereis nginx

nginx-whereis.png

启动、停止nginx

cd /usr/local/nginx/sbin/
./nginx 
./nginx -s stop
./nginx -s quit
./nginx -s reload

./nginx -s quit:此方式停止步骤是待nginx进程处理任务完毕进行停止。
./nginx -s stop:此方式相当于先查出nginx进程id再使用kill命令强制杀掉进程。

查询nginx进程:

ps aux|grep nginx

重启 nginx

1.先停止再启动(推荐):
对 nginx 进行重启相当于先停止再启动,即先执行停止命令再执行启动命令。如下:

./nginx -s quit
./nginx

2.重新加载配置文件:
当 ngin x的配置文件 nginx.conf 修改后,要想让配置生效需要重启 nginx,使用-s reload不用先停止 ngin x再启动 nginx 即可将配置信息在 nginx 中生效,如下:
./nginx -s reload

启动成功后,外网访问浏览http://ip或者http://ip:80 ,出现下面画面说明安装成功:

nginx-welcome.png

开机自启动

即在rc.local增加启动代码就可以了。

vi /etc/rc.local

增加一行 /usr/local/nginx/sbin/nginx
设置执行权限:

chmod 755 rc.local

nginx-rclocal.png

到这里,nginx就安装完毕。

我用这种方法设置开机启动失败。直接用了

systemctl enable nginx   设置开机启动

设置成功。

PS:1.上面是通过cd 进入Nginx的安装目录,然后进行Nginx的启动、停止、重启等操作。

不用进安装目录操作方法:

systemctl start nginx    启动
systemctl enable nginx   设置开机启动

  2.安装成功,访问80 没有出现成功的页面,多半是因为防火墙没添加80端口的问题:

         Nginx默认开启80端口,我们要把80端口添加到防火墙中,添加完以后重启防火墙:

firewall-cmd --zone=public --add-port=80/tcp --permanent

firewall-cmd --reload 重启防火墙

参考:

https://www.cnblogs.com/zhoading/p/8514050.html

https://www.cnblogs.com/dotnet261010/p/12169294.html

标签智能推荐:

Debian11开启bbr

Debian11已把bbr编进内核中,如果版本低需要先升级Linux的内核,编辑/etc/sysctl.conf文件,添加以下内容net.core.default_qdisc=fqnet.ipv4.tcp_congestion_control=bbr或直接用命令修改echo"net.core.default_qdisc=fq">>/etc/sysctl.confecho"net.ipv

.NET平台系列27:在 Linux 上安装 .NET Core/.NET5/.NET6

nbsp;  .NET在不同的Linux发行版上可用。大多数Linux平台和发行版每年都有一个主要版本,并提供用于安装.NET的包管理器。本文介绍当前支持的版本以及使用的包管理器。本文其余部分详细介绍了.NET支持的每个主要Linux发行版。所有.NET版本在 .NETCore版本达到支持终止日期或Linux发行版达到生命周期之前仍受支持。为了实现最佳兼容性,请选择长

Docker最全教程——.NET5进一步拥抱容器技术

net/core:.NETCoredotnet/core/sdk:.NETCoreSDKdotnet/core/aspnet:ASP.NETCoreRuntimedotnet/core/runtime:.NETCoreRuntimedotnet/core/runtime-deps:.NETCoreRuntimeDependenciesdotnet/core/samples:.NETCoreSamp

.NET平台系列28:在 macOS 上安装 .NET Core/.NET5/.NET6

sp; 在本文中,你将了解如何在macOS上安装.NET。.NET由运行时和SDK组成。运行时用于运行.NET应用,应用可能包含也可能不包含它。SDK用于创建.NET应用和库。.NET运行时始终随SDK一起安装。最新版本的.NET是5.0。点击此处,下载.NETCore/.NET。不支持的版本以下.NET版本❌不再受到支持。这些版本的下载仍保持发布状态:3.0(发行说明)2.2(发行说明

龙芯开源社区上线.NET主页

oreclr,随后受到.NET社区的很大参与热情鼓舞之下,2020年7月7日,龙芯团队在github发布了corefx:https://github.com/gsvm/corefx、core-setup:https://github.com/gsvm/core-setup。2020年7月9日,龙芯团队发布了dotnet运行时、aspnetcore运行时与sdk的EA版本,见loongson-dot

在 WSL Ubuntu 上使用 .NET 进行跨平台开发新手入门

t-prod.deb现在当你更新apt时,你会看到微软资源库已检查升级了:安装.NETSDK使用apt从微软资源库安装.NET和相关依赖项:sudoapt-getinstalldotnet-sdk-3.1-y新建工作区创建一个新的工作目录并打开该目录:mkdirdotnetprojectcddotnetproject/新建一个.NET项目使用dotnetnew创建一个新的.NET控制台项目,这会创

dotnet core 在 MIPS64 下的移值进度:EA 版本已经发布

efxgsvm/corefx标准库源码2020/7/7合并入dotnet/runtimedotnet/core-setupgsvm/core-setup编译仓库2020/7/7合并入dotnet/runtimedotnet/core-setup比较特殊,它是用来用来编译runtime,类库和宿主程序的仓库,注意直到这一步dotnet命令才终于可用。具体的编译相关命令已从这里移除,避免过时信息产生误

在 Ubuntu 上安装 .NET SDK 或 .NET 运行时

h-cn/dotnet/core/install/linux-ubuntuUbuntu支持.NET。本文介绍如何在Ubuntu上安装.NET。如果Ubuntu版本不受支持,则该版本不再支持.NET。如果要开发.NET应用,请安装SDK(包括运行时)。或者,如果只需运行应用程序,请安装运行时。如果要安装该运行时,建议安装ASP.NETCore运行时,因为它同时包括.NET和ASP.NETCore运行

《步步入门》 .NET 6 部署到Linux

0.64版本的,不过你也选择其他Linux系统,不过需要注意的是,你选择的Linux系统版本和.core版本是否适配.从https://docs.microsoft.com/zh-cn/dotnet/core/install/linux?WT.mc_id=dotnet-35129-website可以查看详细的各个Linux系统和.NET的版本适配。从图中看到目前只显示最高支持5.0,经测试最新版的

asp.net core2.0网站的环境搭建和网站部署

4e00u53f7dotnet]#dotnet--info  2、3、4也可参考官网给的操作,安装sdk版也可以。https://www.microsoft.com/net/download/linux  5.项目发布.netcore项目在不制定具体端口的情况下,会默认使用5000端口Program.cs添加.UseUrls("http://*:80")使用